Google Chrome va elimina compatibilitate cu plug-in-urile Netscape în septembrie 2015

Autori: Dorian Prodan, Liviu - Andrei Mihai 25.11.2014
Google Chrome va elimina compatibilitate cu plug-in-urile Netscape în septembrie 2015

Google a anunţat acum un an că va restricţiona utilizarea vechilor plug-in-uri Netscape în cadrul browser-ului Chrome, acesta fiind primul pas către eliminarea unui balast care datează de la jumătatea anilor `90. Compania a anunţat că toate aceste plug-in-uri vor fi blocate în mod implicit începând cu ianuarie 2015 şi că Google Chrome va abandona definitiv suportul pentru acestea începând cu septembrie 2015

Apărută la jumătatea anilor `90, odată cu versiunea 2.0 a browser-ului Netscape Navigator, arhitectura multiplatformă NPAPI a permis scrierea unor plug-in-uri care au extins facilităţile oferite de browsere. Java, Flash sau Real Media sunt doar câteva dintre cele mai cunoscute, dar plug-in-urile Netscape a fost mult mai numeroase şi acestea au contribuit la evoluţia Internet-ului către forma pe care o cunoaştem astăzi. Odată cu includerea unui număr tot mai mare de tehnologii direct în browser, cu apariţia unor standarde noi precum HTML5, cu scăderea dependenţei de platforme precum Java şi cu creşterea numărului de ameninţări malware online, plug-in-urile NPAPI şi-au pierdut din importanţă şi au devenit o problemă.

Google a anunţat în luna septembrie a anului trecut că va bloca încărcarea automată a plug-in-urilor Netscape în cadrul browser-ului Chrome şi va activa în mod implicit doar modulele considerate importante şi sigure, cum ar fi Silvelight, Unity sau Google Talk. Odată cu apariţia versiunii pe 64 de biţi a browser-ului Chrome, lista plug-in-urilor NPAPI a devenit şi mai mică, şi, odată cu începutului anului viitor, utilizatorii Chrome vor fi încurajaţi să renunţe definitiv la ele. Datele culese de Google arată că procentul utilizatorilor care activează cel puţin o dată pe lună un plug-in variază între 11 şi 0,1 procente, cifrele scăzând constant în urma migraţiei site-urilor la tehnologii noi.

Începând cu ianuarie 2015, Google Chrome va renunţa şi la lista curentă de excepţii şi va bloca în mod implicit toate plug-in-urile Netscape. Compania va face un pas suplimentar în aprilie 2015, atunci când va bloca posibilitatea de activare manuală a plug-in-urilor NPAPI şi va elimina din Chrome Web Store toate extensiile bazate pe această arhitectură.

Utilizatorii Chrome din mediul business vor avea o perioadă de graţie până în septembrie 2015, politicile centralizate de management urmând să permită activarea implicită a unor plug-in-uri critice timp de încă patru luni. Începând cu luna septembrie a anului viitor, browser-ul Google Chrome va renunţa însă definitiv la compatibilitatea NPAPI, iar dezvoltatorii Web vor trebui să se orienteze fie către tehnologiile HTML5 care nu necesită plug-in-uri, fie către rescrierea plug-in-urilor în formatul nativ Pepper Plugin API, fie către împachetarea sub forma unor aplicaţii Native Client.

Tags: