Cum instalezi extensiile incompatibile în Firefox 3.5

01.07.2009
Cum instalezi extensiile incompatibile în Firefox 3.5

Firefox 3.5 a apărut de aproape o zi dar mulţi useri evită să-l instaleze de teamă că extensiile preferate nu funcţionează. Într-adevăr, problemele de compatibilitate ale extensiilor cu versiunile noi de Firefox este una dintre cele mai mari probleme ale browser-ului celor de la Mozilla. Cu toate astea nu trebuie să disperi, există mai multe modalităţi prin care poţi instala extensiile incompatibile în Firefox 3.5.

Metoda rapidă

Prima metodă prin care poţi constrânge Firefox 3.5 să instaleze extensiile incompatibile implică puţină joacă cu "setările ascunse" ale browser-ului. Pe scurt, folosind această metodă vei obliga Firefox să nu mai verifice compatibilitatea extensiilor cu versiunea curentă, ci să le instalaze indiferent dacă sunt sau nu compatibile.

Nu este deloc complicat:

  • deschizi un tab nou în care scrii about:config şi dai Enter
  • cauţi în listă intrarea "extensions.checkCompatibility" (poţi folosi căsuţa Filter pentru a o găsi rapid)
  • dai dublu click pe această intrare pentru a schimba valoarea din "true" în "false"
  • restartezi Firefox

Firefox 3.5

În acest fel, Firefox nu va mai verifica dacă extensia pe care urmează să o instalezi este compatibilă cu versiunea curentă.

Metoda comodă

Metoda pe care o numesc comodă constă în instalarea unei extensii care facilitează, printre altele, instalarea extensiilor incompatibile. Se numeşte MR Tech Toolkit şi, din fericire, este actualizată frecvent, astfel încât este compatibilă mai mereu cu cele mai noi versiuni de Firefox.

Meniul de configurare al extensiei îţi permite să activezi sau să dezactivezi verificarea compatibilităţii. Dacă vrei ca Firefox să poată instala şi extensiile incompatibile trebuie să debifezi opţiunea "Enable Addons Compatibility Checking", precum în imaginea alăturată.

Firefox 3.5

Metoda "lucru manual"

Ultima metodă este şi cea mai complicată. Aceasta presupune modificarea unui fişier din cadrul extensiei. Explicaţia pe larg poate fi găsită aici.

Aceste metode permit instalarea extensiilor incompatibile dar nu elimină eventualele incompatibilităţi. Unele extensii incompatibile pot funcţiona incorect sau pot influenţa negativ comportamentul browser-ului. De regulă însă, majoritatea extensiilor funcţionează corect chiar dacă sunt etichetate ca fiind incompatibile.

Mozilla spune că, la ora lansării Firefox 3.5, 85% din extensiile populare sunt deja compatibile. Cu toate astea, extensii importante, precum Tab Mix Plus sau Google Gears, nu au încă o versiune finală compatibilă cu Firefox 3.5.

Descarcă Firefox 3.5

Tags: