Cum poţi instala extensiile de Firefox incompatibile

20.05.2008
Cum poţi instala extensiile de Firefox incompatibile

Una dintre cele mai mari frustrări la care ne supune Firefox (alături de leak-urile de memorie) este incompatibilitatea extensiilor cu versiunile noi. De fiecare dată când instalăm o versiune nouă de Firefox, cum este recent lansatul Firefox 3 RC 1, majoritatea extensiilor nu merg pentru că trebuie să fie actualizate de autorii lor. Aşa că, de obicei, utilizatorii folosesc noile versiuni de Firefox cu extensiile dezactivate şi aşteaptă cuminţii până când autorii lor au timp şi chef să rezolve problema compatibilităţii.

Numai că există şi modalităţi prin care utilizatorul poate interveni asupra extensiilor preferate, astfel încât să le facă să fie compatibile cu cea mai nouă versiune de Firefox. Ideea este simplă. Fiecare extensie are specificate versiunile de Firefox pentru care merge (a se citi a fost testată), iar tot ce are de făcut utilizatorul este să modifice numărul versiunii trecute de autorul extensiei. Chiar dacă sună complicat, nu este deloc aşa.

Pentru această operaţiune recomand folosirea programului Total Commander ca manager de fişiere. Se poate face şi din Windows Explorer, dar Total Commander are o serie de facilităţi care îţi va simplifica munca.

Transformarea extensiei în arhivă

Primul pas constă în salvarea pe calculator a extensiei dorite. Pentru asta intri pe site-ul de addon-uri pentru Firefox şi – în loc să instalezi extensia în Firefox – dai click dreapta pe link-ul de instalare şi alegi opţiunea Save Link As. Addon-urile de Firefox au extensia .xpi şi sunt de fapt un fel de arhive care conţin la rândul lor alte fişiere.

Pentru a putea modifica extensia, trebuie mai întâi să poţi accesa fişierele pe care aceasta le conţine. Aşa că al doilea pas constă în schimbarea extensiei fişierului din .xpi în .zip. Odată schimbată extensia, poţi folosi Total Commander pentru a o accesa. În interiorul ei sunt mai multe fişiere, dar nu te interesează decât cel numit install.rdf. Nu este nevoie să îl extragi din arhivă pentru a-l edita, cu Total Commander îl poţi modifica direct în arhivă.

extensii firefox

Editarea în Notepad

Apeşi F4 pe fişierul install.rdf pentru a-l deschide în Notepad. În cadrul fişierului dai search după cuvântul "maxVersion" (dacă estensia merge şi în alte programe, cuvântul va apărea de mai multe ori, dar nu te interesează decât prima apariţie, cea care face referire la Firefox). În dreptul lui este trecut numărul celei mai recente versiuni de Firefox pentru care este permisă instalarea extensiei. Dacă, să zicem, este trecut numărul 2.10, înseamnă că extensia respectivă nu poate fi instalată pe extensiile mai noi decât 2.10. Dacă tu vrei să instalezi extensia în cauză pe Firefox 3 nu trebuie decât să scrii 3.0 în loc de 2.10. Salvezi şi închizi fişierul. Total Commander te va întreba dacă vrei ca modificările făcute să fie salvate prin suprascrierea fişierului original din arhivă, mesaj la care trebuie să dai Yes.

extensii firefox

După editarea fişierului, trebuie să schimbi extensia fişierului la loc, din .zip în .xpi, pentru a o putea instala în Firefox. Instalarea se va face simplu, prin drag&drop în fereastra de Firefox. Restart şi asta e tot.

Această operaţiune nu rezolvă eventualele probleme de compatibilitate dintre extensie şi program, ci doar "păcălesc" browser-ul să accepte instalarea extensiei. Este posibil ca extensia să nu meargă cum trebuie sau chiar deloc. Însă, din experienţă, majoritatea extensiilor merg corect după aceste modificări. Dintre cele mai populare extensii, am avut probleme doar cu Tab Mix Plus şi Forecastfox.